• Welcome to Righteous Wrath Online Community. Please login or sign up.
 
September 21, 2020, 10:38:30 PM

Default theme change

Started by Lazybones, April 20, 2015, 11:52:16 AM

Previous topic - Next topic

Lazybones

I have applied a minor change the to default forum theme.

Let me know if you encounter any issues.

Thorin

Prayin' for a 20!

gcc thorin.c -pedantic -o Thorin
compile successful

Lazybones

Quote from: Thorin on April 20, 2015, 01:43:02 PM
What change it is?



Some beta improvements for smaller screen devices, nothing drastic.

Darren Dirt

By the way on my Android phone the forum is showing up weird -- fine when I show last 10 posts, but if I go to any specific thread then I do not see some things (cant think exactly what, it just looks sparse) PLUS (the biggie!) there is no date-time for each individual post!

Perhaps a recent upgrade broke it and I only noticed today... I am using the same theme as forever (default iirc).


A visual demo tomorrow will clarify if needed... cya then!

_____________________

Get better at getting better. Daily.
_____________________

Thorin

Prayin' for a 20!

gcc thorin.c -pedantic -o Thorin
compile successful

Darren Dirt

Quote from: Thorin on June 02, 2015, 07:22:21 PM
Are you using Tapatalk?


Nope.

Maybe the default theme got changed to be Tapatoptimized?

_____________________

Get better at getting better. Daily.
_____________________

Tom

Quote from: Darren Dirt on June 03, 2015, 06:45:19 AM
Quote from: Thorin on June 02, 2015, 07:22:21 PM
Are you using Tapatalk?


Nope.

Maybe the default theme got changed to be Tapatoptimized?




As my internet is down I thought I'd check on my phone...

<Zapata Prime> I smell Stanley... And he smells good!!!

Melbosa

Mine does that now as well (Windows Phone).  I think it was with the last security patch or something...  the annoying part is the pushed to the left part at the bottom of his screen shot.
Sometimes I Think Before I Type... Sometimes!

Lazybones

There is a thread in the help section about recent changes I have made to themes.

There was a patch applied were I removed the optional mobile theme and installed the new "responsive" theme that should work on all screen sizes. It should be sparse but not lose function...

Tom

Quote from: Lazybones on June 03, 2015, 04:08:54 PM
There is a thread in the help section about recent changes I have made to themes.

There was a patch applied were I removed the optional mobile theme and installed the new "responsive" theme that should work on all screen sizes. It should be sparse but not lose function...
its certainly trying to be responsive.. But its wrapping/flowing parts wrong. Check threads as well.. It even does weird things in landscape. Maybe some theme files are conflicting?
<Zapata Prime> I smell Stanley... And he smells good!!!

Lazybones

There was an update to the default theme released I have just applied it..


Do a full refresh and let me know if it improves things.

Melbosa

Looks fixed to me on my Windows Phone now.
Sometimes I Think Before I Type... Sometimes!

Lazybones


Quote from: Darren Dirt on June 03, 2015, 06:45:19 AM
Quote from: Thorin on June 02, 2015, 07:22:21 PM
Are you using Tapatalk?


Nope.

Maybe the default theme got changed to be Tapatoptimized?


On this point, no. Tapatalk uses its own plugin which adds the hook for letting you know it is available and in some cases ensuring links redirect to the app if you are in the app. Other than that the app talks to its plugging directly via its own API.

Tapatalk renders the forums with native widgets on each platform for the most part which is why it it fast and different than mobile browsing.

SMF is building proper responsive elements into the next major release however till then they have releases an official theme mod to patch older / existing forums as google announced page rank penalties for sites that are not mobile friendly.

Darren Dirt

Still not seeing date-time of each individual post in a thread.

But I do see that info when viewing Last10posts or whatever.
_____________________

Get better at getting better. Daily.
_____________________

Lazybones

Quote from: Darren Dirt on June 03, 2015, 05:27:52 PM
Still not seeing date-time of each individual post in a thread.

But I do see that info when viewing Last10posts or whatever.


It appears that text element is removed below a specific horizontal size... I can confirm it does not appear on my phone and if I re-size in my desktop browser it gets removed before some other elements at small window sizes.