• Welcome to Righteous Wrath Online Community. Please login or sign up.
 
September 22, 2020, 02:35:17 PM

Interested in 1.15 on the Server?

Started by Lazybones, December 11, 2019, 08:27:35 PM

Previous topic - Next topic

How bad do you want the server upgraded to 1.15?

Don't upgrade it might break something.
0 (0%)
Meh
0 (0%)
Sure but not in a hurry
1 (25%)
Soon Please
3 (75%)
WHY ARE YOU POSTING POLLS UPGRADE NOW!
0 (0%)

Total Members Voted: 4

Voting closed: December 25, 2019, 08:27:35 PM

Lazybones

1.15 is out but we have a few data packs and we have overviewer to think about.. It looks like there are some issues with overviewer but there are workarounds.. What does everyone think?

Personally I would like to get it upgraded but I mainly want to be sure overviewer works OK and that the datapacks are compatible or updated (haven't checked yet).

Thorin

Honestly, I'm happy to see it go to the new version but I also really don't want Overviewer to stop working again.
Prayin' for a 20!

gcc thorin.c -pedantic -o Thorin
compile successful

Lazybones

Looks like I need to get some testing done. I think overviewer is going to be the only blocker as most of the datapacks should just work or can be removed until they do.

If I can get a reliable overviewer workaround in place I will likely just do the upgrade.

Of note overviewer does not have ANY of the new 1.15 blocks yet so anything built with honey would not be visible but that shouldn't be a deal breaker.

Lazybones

I have preformed some upgrade tests on my smaller home server world and the data packs and world update went well.. I was able to run over viewer in 1.14 mode on the 1.15 world but that world is VERY small.

Checking the overviewer discord apparently there are some new biome variants that can crash overviewer when encountered so it isn't just about missing 1.15 blocks.. There is no release of overviewer with 1.15 fixes yet but the main maintainer has checked in code to that should allow overviewer to process 1.15 worlds and skip the parts it doesn't support.

So at this point there is a VERY high likely hood that NEW chunks will crash overviewer but the existing ones would be fine.

I will see if there is an easy way for me to run a dev build with the basic fixes in it or if there is an ETA on a 1.15 safe release.

Other than that I should be able to upgrade to 1.15 at any time.

Lazybones

December 17, 2019, 10:36:27 AM #4 Last Edit: December 17, 2019, 02:19:52 PM by Lazybones
Looks like overviewer has been patched and the docker I use is up to date.. A little more testing and I will flip the server over.

Mr. Analog

Awesome! Thanks Lazy

Sent from my Pixel 2 XL using Tapatalk

By Grabthar's Hammer

Lazybones

Not sure how quick this will be but I am tentatively planning to have this complete by this weekend at the latest unless I run into some bumps.

Lazybones